mercredi 22 février 2017

STUDIO 440 Sequential Circuits : non mais, n'importe quoi!

J'ai acquis mon Studio 440 en 2006 il me semble, du côté de Lille. La machine proposée avait du vécu, et un fonctionnement parfois 'erratique'. Mais bon, la démonstration faite, qui avait consisté à charger une séquence et des sonorités depuis un disque dur externe m'avait convaincu.


Présenté comme cela, c'est une bien belle machine. De retour chez moi avec une jolie collection de samples sur disque dur, je me suis bien 'amusé'. Assez rapidement cependant, il m'a fallu ouvrir la bête pour corriger des défauts de fonctionnement. Et me rendre compte à ces différentes occasions que je n'avais pas été le premier à l'ouvrir. J'ai remis en état quelques autres 440 depuis, quelques sujets sur ce blog en relatent les déroulements.

Et puis très récemment, je me suis décidé à tenter l'échantillonnage. Aussi invraisemblable que cela puisse paraître, je n'avais jamais tenté le coup. Très rapidement, lors de la procédure de configuration de l' enregistrement, la machine s'arrête et semble carrément plantée. Je lance donc les auto-diagnostics et me rends compte que le lancement du test de rafraichissement de la RAM d’échantillonnage ne se lance pas. Test lancé après celui d'écriture/lecture dans cette même RAM qui lui, se déroule correctement.

Je fais bref : Je suspect donc un plantage de la carte processeur. Après quelques heures, de recherches intensives, j'en conclue que cela ne vient pas de la carte mère, mais de la carte de la face avant. Je suspecte le système électronique de gestion des switchs d'être en cause. Après moult tests et retrait de certains circuits intégrés pour les remplacer ou tout simplement faire fonctionner la machine sans, je n'arrive toujours pas à trouver la cause du problème.

Et puis, en fin de soirée, lors d'un ultime test, je décide de 'valider' les switchs, on ne sait jamais. Pas de raison particulière étant donné que le lancement des fonctions ne pose jamais pas de problème. L'appui sur les différents switchs me donne bien une valeur différente. SAUF QUE, lorsque je relâche un quelconque switch, le chiffre 44 apparaît systématiquement à l'affichage.


Et qu'est-ce donc que le bouton qui se cache derrière le code 44? Le TAP contrôle. Le bouton qui sert à imposer un BPM à la machine.

Incroyable!!! J'avais déjà eu à l'époque bien des soucis avec la procédure de lecture sur disque SCSI qui plantait alors qu'il fallait appuyer sur ENTER pour la lancer! La réponse est là! Mais alors, pour quelle raison ce bouton génère ces problèmes? Tout simplement parce qu'il est en court-circuit!

Je retire ce bouton du circuit imprimé de la machine, et lui enlève la tête dans le but de vérifier l'état de la mécanique :


E là, c'est édifiant. la barre métallique (borne n°1 du switch) tangente au gros ressort n'est pas clipsée dans l'endroit prévu à cet effet et se retrouve du coup très (trop) proche du gros ressort. Ce gros ressort maintien en hauteur le capuchon du bouton ET la barre métallique horizontale (borne n°2 du switch). Et que ce passe-t-il? Et bien le gros ressort est 'flottant' dans son logement. Lors de l'appui et le relâchement du switch, il 'peut' ainsi se retrouver en contact avec les deux bornes et donc continuer à simuler l'appui du bouton. Le côté aléatoire du sujet ne permettant pas, bien évidemment, un diagnostic fiable de la panne!

je ne sais pas de quelle façon doit fonctionner ce switch, mais ce qui est sur, c'est que si la borne n°1 est bien clipsée, lors de l'appui du capuchon du bouton, le gros ressort s'écrase mais n'entraine pas la borne n°2 avec lui. Il n'y a donc pas contact.

Et on en arrive à la raison pour laquelle la borne n°1 n'était pas clipsée. En fait elle a été déclipsée volontairement pour permettre de la souder un peu en hauteur, de façon à ce que le capot du bouton, fasse quand même entrer les deux bornes en contact. Ça, ça fonctionne. Mais au relâchement, le gros ressort n'étant pratiquement plus du tout en pression, il se 'promène' tranquillement et, 'de temps en temps' vient court-circuiter les deux bornes sans qu'une quelconque action extérieur soit nécessaire : amusant non?
Plutôt que d'avoir essayé à l'époque de remplacer ce switch défectueux pendant qu'il était facile d'en trouver un remplaçant. Mais non, la personne étant intervenue a préféré faire du mauvais bricolage!

J'ai donc ressoudé correctement la borne n°1, à sa place initiale, et suffisamment loin du gros ressort, puis j'ai 'enroulé ce gros ressort sur la borne n°2 de façon à ce qu'il l'entraine avec lui  vers le bas et que le contact s'établisse correctement en fin de course :


Je ne pense pas que cela fonctionnait de la sorte à l'origine, mais bon, ça ira bien. J'ai pu tester le fonctionnement correct de ce switch après remontage. Evidemment j'ai remonté ce bouton dans le sens inverse du départ (parce qu'en plus deux positions sont possibles sur le circuit imprimé), ce qui a donnée ceci au remontage de la carte :



Démontage, déssoudage, ressoudage et remontage de la carte obligatoire : hum!!!!

Enfin la récompense : 


Le deuxième test de la mémoire se lance correctement, sélection du bouton n°0 après avoir lancé le test d'écriture/lecture de la RAM avec le bouton n°2.

CONCLUSION : j'espère vraiment être arrivé au bout des problèmes de cette machine, environ 10 ans après l'avoir acquise!

Cela ne fait que renforcer mon sentiment de matériel tendance 'piece of shit' que celui de Sequential sur cette période. Et... je sais de quoi je parle, je possède un Prophet VS, un Studio 440 et un Prophet 3000. Tous ces produits présentent les mêmes symptômes : études mal réalisées avec des erreurs grossières de conception, design et mise en boîte avec des solutions technique des plus 'merdiques', systèmes bugués comme dans le cas de ce studio 440 (même pas capable de 'pondre' une routine de gestion de touches correcte) ou pas finies comme sur le Prophet 3000. Composants de mauvaise qualité etc etc... et la liste est longue.

Et pourtant quand ça fonctionne, ça fonctionne bien, et c'est vraiment autre chose. C'est sans doute la raison pour laquelle ces machines sont toujours recherchées. Mais attention, je n'hésite pas à dire qu'il faut posséder une bonne dose de compétences et de patience pour les maintenir en état. Et malgré cela, il reste possible de se faire piéger 'comme un bleu' par une 'double erreur' donnant l’impression d'un fonctionnement correct!

J'ai corrigé pas mal de bugs de mon Prophet 3000. Dont notamment le gros circuit fourni par Yamaha pour gérer correctement l'extension mémoire. Sauf que cela ne fonctionne pas parce qu'il y a des erreurs sur les bits d'adresse de cette extension. Heureusement, j'ai fini par avoir les bonnes infos et les corrections à effectuer sur la carte mère du 3000 mais n'ai pas encore tenté de les mettre en application. Le ferais-un jour? Je ne sais pas. Essayer de faire fonctionner un Prophet 3000 serait comme, hum... Ou alors l'exposer dans un musée, comme une espèce de dinosaure nouvellement découverte ;-)


Aucun commentaire:

Enregistrer un commentaire